24h購物| | PChome| 登入
2014-03-02 12:38:03| 人氣1,611| 回應0 | 上一篇 | 下一篇

[UVA][貪婪] 11691 - Allergy Test

推薦 0 收藏 0 轉貼0 訂閱站台

Problem C - Allergy Test

Time limit: X seconds

A test for allergy is conducted over the course of several days, and consists of exposing you to different substances (so called allergens). The goal is to decide exactly which of the allergens you are allergic to. Each allergen has a live duration D measured in whole days, indicating exactly how many days you will suffer from an allergic reaction if you are allergic to that particular substance. An allergic reaction starts to show almost immediately after you have been exposed to an allergen which you are allergic to. The test scheme has two action points per day:

  1. At 8 o'clock each morning, at most one of the allergens is applied to your body.
  2. At 8 o'clock each evening, you are examined for allergic reactions.
Thus an allergen with live duration D will affect exactly D allergic reaction examinations. Of course, if you have two or more active allergens in your body at the time of an observed reaction, you cannot tell from that information only, which of the substances you are allergic to. You want to find the shortest possible test scheme given the durations of the allergens you want to test. Furthermore, to allow simple large scale application the test scheme must be non-adaptive, i.e. the scheme should be fixed in advance. Thus you may not choose when to apply an allergen based on the outcome of previous allergic reaction examinations.

Input

The first line of the input file contains an integer N (N<30) which denotes the total number of test cases. The description of each test case is given below:

The first line of the input contains a single integer k (1 ≤ k ≤ 20) specifying the number of allergens being tested for. Then follow k lines each containing an integer D (1 ≤ D ≤ 7) specifying the live duration of each allergen.

Output

For each test case, print in a single line the number of days of the shortest conclusive non-adaptive test scheme. A scheme ends the morning when you no longer have active allergens in your body, thus a test scheme for a single allergen with live duration D takes D days.

Sample Input

2
3
2
2
2
5
1
4
2
5
2

Sample Output

5
10

The 2009 ACM Nordic Collegiate Programming Contest

參照作法 par.cse.nsysu.edu.tw/~advprog/advprog2011/11691.ppt

#include <stdio.h>
#include <algorithm>
#include <functional>
using namespace std;

int main() {
    int testcase;
    int n, A[80];
    int i, j, k;
    scanf("%d", &testcase);
    while(testcase--) {
        scanf("%d", &n);
        for(i = 0; i < n; i++)
            scanf("%d", &A[i]);
        sort(A, A+n, greater<int>());
        int ret = 0xfffffff;
        for(i = 0; i < A[0]; i++) {
            int l = i, r = A[0] - i - 1;
            int cost = A[0];
            for(j = 1; j < n; j++) {
                int cl, cr; // cover
                cl = min(l, A[j] - 1);
                cr = min(r, A[j] - 1);
                if(cl > cr)
                    l = A[j] - cl - 1, cost += l + 1;
                else
                    r = A[j] - cr - 1, cost += r + 1;
            }
            ret = min(ret, cost);
        }
        printf("%d\n", ret);
    }
    return 0;
}

台長: Morris
人氣(1,611) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 教育學習(進修、留學、學術研究、教育概況) | 個人分類: UVA |
此分類下一篇:[UVA][概率] 11680 - Dragster
此分類上一篇:[UVA][離散化、Dinic] 11358 - Faster Processing Feasibility

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文