24h購物| | PChome| 登入
2013-07-12 08:01:16| 人氣808| 回應0 | 上一篇 | 下一篇

[UVA] 1197 - The Suspects

推薦 0 收藏 0 轉貼0 訂閱站台

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input 

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n$ le$30000 and 0$ le$m$ le$500. Every student is numbered by a unique integer between 0 and n - 1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case wit n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output 

For each case, output the number of suspects in one line.

Sample Input 

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output 

4
1
1

首先會是 0 當作感染的嫌疑人,接著與 0 相同社團的的人同樣也會當作嫌疑人,
而這些嫌疑人所在的社團的人同樣會是嫌疑人。
問嫌疑人共有多少?

很明顯地看出要找到一個連通元件,建圖的部分隨便找一個社團中的一人,將所有人連向她即可。

#include <stdio.h>
#include <vector>
using namespace std;
vector<int> g[30005];
int used[30005], ret;
void dfs(int x) {
ret++, used[x] = 1;
for(vector<int>::iterator it = g[x].begin();
it != g[x].end(); it++) {
if(used[*it] == 0) {
dfs(*it);
}
}
}
int main() {
int n, m, k;
int i, j, x, y;
while(scanf("%d %d", &n, &m) == 2 && n) {
for(i = 0; i <= n; i++)
g[i].clear(), used[i] = 0;
while(m--) {
scanf("%d", &k);
scanf("%d", &x), k--;
while(k--) {
scanf("%d", &y);
g[x].push_back(y);
g[y].push_back(x);
}
}
ret = 0;
dfs(0);
printf("%d\n", ret);
}
return 0;
}
 

台長: Morris
人氣(808) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][并查集] 1160 - X-Plosives
此分類上一篇:[UVA][最短路] 1112 - Mice and Maze

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文