24h購物| | PChome| 登入
2012-07-06 08:22:58| 人氣1,242| 回應0 | 上一篇 | 下一篇

[UVA] 442 - Matrix Chain Multiplication

推薦 0 收藏 0 轉貼0 訂閱站台


 Matrix Chain Multiplication 

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125



#include <stdio.h>
int n, i, j, k;
int alpha[105][2];
char s[105];
void solve() {
    int stack[105], sidx = -1;
    int sum = 0, alidx = 'Z';
    for(i = 0; s[i]; i++) {
        if(s[i] == '(') {
            stack[++sidx] = '(';
        } else if(s[i] == ')'){
            j = sidx;
            while(stack[j] != '(')
                j--;
            for(k = j+1; k < sidx; k++) {
                if(alpha[stack[k]-'A'][1] != alpha[stack[k+1]-'A'][0]) {
                    //printf("%d %d %d %d\n", alpha[stack[k]-'A'][0], alpha[stack[k]-'A'][1], alpha[stack[k+1]-'A'][0], alpha[stack[k+1]-'A'][1]);
                    puts("error");
                    return;
                }
                sum += alpha[stack[k]-'A'][0]*alpha[stack[k]-'A'][1]*alpha[stack[k+1]-'A'][1];
            }
            alidx++;
            alpha[alidx-'A'][0] = alpha[stack[j+1]-'A'][0];
            alpha[alidx-'A'][1] = alpha[stack[sidx]-'A'][1];
            //printf("%d %d %d\n", alpha[alidx][0], alpha[alidx][1], alidx);
            stack[j] = alidx;
            sidx = j;
        } else
            stack[++sidx] = s[i];
    }
    printf("%d\n", sum);
}
int main() {
    int x, y;
    scanf("%d", &n);
    for(i = 0; i < n; i++) {
        scanf("%s %d %d", s, &x, &y);
        alpha[s[0]-'A'][0] = x;
        alpha[s[0]-'A'][1] = y;
    }
    while(scanf("%s", s) == 1) {
        solve();
    }
    return 0;
}

台長: Morris
人氣(1,242) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 478 - Points in Figures: Rectangles ...
此分類上一篇:[UVA][map&set混用] 11239 - Open Source

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文