24h購物| | PChome| 登入
2012-06-27 21:57:17| 人氣675| 回應0 | 上一篇 | 下一篇

[UVA] 585 - Triangles

推薦 0 收藏 0 轉貼0 訂閱站台


  Triangles 

It is always very nice to have little brothers or sisters. You can tease them, lock them in the bathroom or put red hot chili in their sandwiches. But there is also a time when all meanness comes back!


As you know, in one month it is Christmas and this year you are honored to make the big star that will be stuck on the top of the Christmas tree. But when you get the triangle-patterned silver paper you realize that there are many holes in it. Your little sister has already cut out smaller triangles for the normal Christmas stars. Your only chance is to find an algorithm that tells you for each piece of silver paper the size of the largest remaining triangle.


Given a triangle structure with white and black fields inside you must find the largest triangle area of white fields, as shown in the following figure.

Input 

The input file contains several triangle descriptions. The first line of each description contains an integer n ( $1 leŸ n leŸ 100$), which gives the height of the triangle. The next n lines contain characters of the set {space, #, -} representing the rows of the triangle, where `#' is a black and `-' a white field. The spaces are used only to keep the triangle shape in the input by padding at the left end of the lines. (Compare with the sample input. The first test case corresponds to the figure.)

For each triangle, the number of the characters `#' and `-' per line is odd and decreases from 2n - 1 down to 1.


The input is terminated by a description starting with n = 0.

Output 

For each triangle in the input, first output the number of the triangle, as shown in the sample output. Then print the line ``The largest triangle area is a.'', where a is the number of fields inside the largest triangle that consists only of white fields. Note that the largest triangle can have its point at the top, as in the second case of the sample input.


Output a blank line after each test case.

Sample Input 

5
#-##----#
 -----#-
  ---#-
   -#-
    -
4
#-#-#--
 #---#
  ##-
   -
0

Sample Output 

Triangle #1
The largest triangle area is 9.

Triangle #2
The largest triangle area is 4.


這題好像在 ITSA 看過, 可能是眼花了吧
 


#include <stdio.h>

int main() {
    int n, i, j, k, l, test = 0;
    char map[105][300];
    while(scanf("%d", &n) == 1) {
        if(n == 0)
            break;
        for(i = 0; i < n; i++)
            scanf("%s", map[i]);
        int ans = 0;
        for(i = 0; i < n; i++) {
            for(j = 0; j < 2*n-i; j++) {
                int cnt = 0;
                if(j&1) {
                    for(k = i; k < n; k++) {
                        for(l = j-(k-i)*2; l <= j; l++) {
                            if(l < 0 || l >= 2*n-k)
                                break;
                            if(map[k][l] != '-')
                                break;
                            cnt++;
                        }
                        if(l != j+1)
                            break;
                        if(cnt > ans)
                            ans = cnt;
                    }
                } else {
                    for(k = i; k >= 0; k--) {
                        for(l = j; l <= j+(i-k)*2; l++) {
                            if(l < 0 || l >= 2*n-k)
                                break;
                            if(map[k][l] != '-')
                                break;
                            cnt++;
                        }
                        if(l != j+(i-k)*2+1)
                            break;
                        if(cnt > ans)
                            ans = cnt;
                    }
                }
            }
        }
        printf("Triangle #%d\n", ++test);
        printf("The largest triangle area is %d.\n\n", ans);
    }
    return 0;
}

台長: Morris
人氣(675) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 12027 - Very Big Perfect Squares
此分類上一篇:[UVA][并查集變形] 11987 - Almost Union-Find

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文