24h購物| | PChome| 登入
2012-04-09 15:04:13| 人氣1,055| 回應0 | 上一篇 | 下一篇

[UVA][DP] 10313 - Pay the Price

推薦 0 收藏 0 轉貼0 訂閱站台

Problem B

Pay the Price

Input: standard input

Output: standard output

Time Limit: 2 seconds

Memory Limit: 32 MB

 

In ancient days there was a country whose people had very interesting habits. Some of them were lazy, some were very rich, some were very poor and some were miser. Obviously, some of the rich were miser (A poor was never miser as he had little to spend) and lazy but the poor were lazy as well (As the poor were lazy they remained poor forever). The following things were true for that country

 

a)      As the rich were miser, no things price was more than 300 dollars (Yes! their currency was dollar).

b)      As all people were lazy, the price of everything was integer (There were no cents and so beggars always earned at least one dollar)

c)      The values of the coins were from 1 to 300 dollars, so that the rich (who were idle) could pay any price with a single coin.

 

Your job is to find out in how many ways one could pay a certain price using a limited number of coins (Note that the number of coins paid is limited but not the value or source. I mean there was infinite number of coins of all values). For example, by using three coins one can pay six dollars in 3 ways, 1+1+4, 1+2+3, and 2+2+2. Similarly, one can pay 6 dollars using 6 coins or less in 11 ways.

 

Input

The input file contains several lines of input. Each line of input may contain 1, 2 or 3 integers. The first integer is always N (0<=N<=300), the dollar amount to be paid. All other integers are less than 1001 and non-negative.

 

Output

For each line of input you should output a single integer.

 

When there is only one integer N as input, you should output in how many ways N dollars can be paid.

 

When there are two integers N and L1 as input, then you should output in how many ways N dollars can be paid using L1 or less coins.

 

When there are three integers N, L1 and L2 as input, then you should output in how many ways N dollars can be paid using L1, L1+1 …, L2 coins (summing all together). Remember that L1 is not greater than L2.

 

Sample Input

6

6 3

6 2 5

6 1 6

 

Sample Output

11

7

9

11

時間都耗在輸入 ...

#include <stdio.h>
#include <iostream>
#include <sstream>
using namespace std;

int main() {
    long long DP[301][301] = {};
    int i, j, k;
    char str[1000];
    DP[0][0] = 1;
    for(i = 1; i <= 300; i++) {
        for(j = i; j <= 300; j++) {
            for(k = 1; k <= j; k++)
                DP[j][k] += DP[j-i][k-1];
        }
    }
    while(gets(str)) {
        stringstream sin(str);
        int num[3], n = 0;
        while(sin >> num[n])
            n++;
        int p, q;
        if(n == 1)   
            p = 0, q = num[0];
        else if(n == 2)
            p = 0, q = num[1];
        else
            p = num[1], q = num[2];
        n = num[0];
        if(q > n)    q = n;
        long long ans = 0;
        for(i = p; i <= q; i++)
            ans += DP[n][i];
        printf("%lld\n", ans);
    }
    return 0;
}

台長: Morris
人氣(1,055) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][LIS] 437 - The Tower of Babylon
此分類上一篇:[UVA][LIS] 497 - Strategic Defense Initiative

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文