24h購物| | PChome| 登入
2011-12-03 09:10:23| 人氣2,804| 回應0 | 上一篇 | 下一篇

[UVA] 202 - Repeating Decimals

推薦 0 收藏 0 轉貼0 訂閱站台

 Repeating Decimals 

The decimal expansion of the fraction 1/33 is tex2html_wrap_inline43 , where the tex2html_wrap_inline45 is used to indicate that the cycle 03 repeats indefinitely with no intervening digits. In fact, the decimal expansion of every rational number (fraction) has a repeating cycle as opposed to decimal expansions of irrational numbers, which have no such repeating cycles.

Examples of decimal expansions of rational numbers and their repeating cycles are shown below. Here, we use parentheses to enclose the repeating cycle rather than place a bar over the cycle.

tabular23

Write a program that reads numerators and denominators of fractions and determines their repeating cycles.

For the purposes of this problem, define a repeating cycle of a fraction to be the first minimal length string of digits to the right of the decimal that repeats indefinitely with no intervening digits. Thus for example, the repeating cycle of the fraction 1/250 is 0, which begins at position 4 (as opposed to 0 which begins at positions 1 or 2 and as opposed to 00 which begins at positions 1 or 4).

Input

Each line of the input file consists of an integer numerator, which is nonnegative, followed by an integer denominator, which is positive. None of the input integers exceeds 3000. End-of-file indicates the end of input.

Output

For each line of input, print the fraction, its decimal expansion through the first occurrence of the cycle to the right of the decimal or 50 decimal places (whichever comes first), and the length of the entire repeating cycle.

In writing the decimal expansion, enclose the repeating cycle in parentheses when possible. If the entire repeating cycle does not occur within the first 50 places, place a left parenthesis where the cycle begins - it will begin within the first 50 places - and place ``...)" after the 50th digit.

Print a blank line after every test case.

Sample Input

76 25
5 43
1 397

Sample Output

76/25 = 3.04(0)
   1 = number of digits in repeating cycle

5/43 = 0.(116279069767441860465)
   21 = number of digits in repeating cycle

1/397 = 0.(00251889168765743073047858942065491183879093198992...)
   99 = number of digits in repeating cycle



萬惡的輸出格式

#include<stdio.h>
#include<string.h>
int main() {
    int n, m;
    int mark[3001], i, j;
    while(scanf("%d %d", &n, &m) == 2) {       
        char s[3001], *str = s+1;
        memset(mark, 0, sizeof(mark));
        printf("%d/%d = %d.", n, m, n/m);
        n %= m;
        mark[n] = 1;
        n *= 10;
        for(i = 2; ; i++) {
            *str = n/m + '0', str++;           
            if(mark[n%m])    break;
            mark[n%m] = i;
            n %= m;
            n = n*10;
        }
        int st = mark[n%m], ed = i;
        for(j = 1; j < ed && j <= 50; j++) {
            if(j == st)    printf("(");
            printf("%c", s[j]);
        }
        if(j < ed)    printf("...");
        printf(")\n");   
        printf("   %d = number of digits in repeating cycle\n\n", ed-st);
    }
    return 0;
}

  

                                                        

台長: Morris
人氣(2,804) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 1124 - Celebrity jeopardy
此分類上一篇:[UVA] 200 - Rare Order

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文