24h購物| | PChome| 登入
2013-07-02 09:20:40| 人氣1,146| 回應0 | 上一篇 | 下一篇

[UVA][窮舉] 129 - Krypton Factor

推薦 0 收藏 0 轉貼0 訂閱站台


 Krypton Factor 

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

  • BB
  • ABCDACABCAB
  • ABCDABCD

Some examples of hard sequences are:

  • D
  • DC
  • ABDAB
  • CBABCBA

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:

A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input

30 3
0 0

Sample Output

ABAC ABCA CBAB CABA CABC ACBA CABA
28

輸入麻煩一點, 每四個字元一組, 一行最多 16 組。

窮舉即可, 邊窮舉邊檢查。


#include <stdio.h>
int n, L, rank;
char s[105];
int check(int L) {
int i, j, k, l;
for(i = L; i >= 0; i--) {
l = L-i+1;
if(l+l > L+1) break;
for(j = i-l, k = i; j < i; j++, k++)
if(s[k] != s[j])
break;
if(j == i)
return 0;
}
return 1;
}
void dfs(int idx) {
if(rank > n) return;
int i;
for(i = 0; i < L; i++) {
s[idx] = 'A'+i;
s[idx+1] = '\0';
if(check(idx)) {
rank++;
if(rank == n) {
for(i = 0; i <= idx; i++) {
if(i == 64) puts("");
else if(i && i%4 == 0)
putchar(' ');
putchar(s[i]);
}
printf("\n%d\n", idx+1);
}
dfs(idx+1);
}
}
}
int main() {
while(scanf("%d %d", &n, &L) == 2) {
if(n == 0) break;
rank = 0;
dfs(0);
}
return 0;
}

台長: Morris
人氣(1,146) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][字串] 126 - The Errant Physicist
此分類上一篇:[UVA][模擬] 10138 - CDVII

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文