24h購物| | PChome| 登入
2013-04-01 23:02:32| 人氣1,014| 回應1 | 上一篇 | 下一篇

[UVA][字串處理] 10146 - Dictionary

推薦 0 收藏 0 轉貼0 訂閱站台

Problem D
"Dictionary"


Authors of the new, all-in-one encyclopedia have organized the titles in the order they consider most appropriate for their readers. It's not always alphabetical, because they want to observe some peculiar relationships between them. However, they still want to allow users to look up titles quickly.

They achieve this by adding a carefully calculated number of spaces before every title in the list of titles. They call this structure a dictionary.

A dictionary is represented by a list of words with some number of spaces before certain words. Dictionary format can be described as a set of constraints on sequences of consecutive words starting with the same letter. Any maximal sequence of consecutive words starting with the same letter should satisfy the following rules:

  • The first word in the group has no spaces before it. Every subsequent word in the group has at least one leading space.
  • If
    • the first word of the group is deleted and
    • one space is deleted before every remaining word and
    • the first letter is deleted from every remaining word
    then resulting sequence is a dictionary.
The authors don't feel like giving you a more detailed explanation of what a dictionary is, so they have included an example (see sample input and output) that clarifies their definition.

Your task is to write a program that will convert a given list of words into a dictionary by adding some number of spaces before certain words and preserving the original order of the words.

Input

The first line of the input contains an integer indicating the number of test cases in the input. Then there is a blank line and the test cases separated by a blank line. Each test case consists of at least one and most 100000 words. Each word consists of at least one and at most 10 lower-case letters. There will be no leading or trailing spaces. There will be no blank lines between the words.

Output

For each test case write to the output file the original words in the same order without any trailing spaces but with the appropriate number of leading spaces, so that this word list is a dictionary. There should be no blank lines between the words. Print a blank line between test cases.

Sample input

1

a
ant
antique
amaze
bargain
bridge
bride
bribe
born
bucket
tart
tan
tram
trolley
t
try
trial
zed
double
dorm
do
dormant
donate
again
agony
boost
back
born

Sample output for the sample input

NOTE: For reading convenience spaces are replaced with '.' characters. Your output file should contain spaces instead.

a
.ant
..antique
.amaze
bargain
.bridge
..bride
...bribe
.born
.bucket
tart
.tan
.tram
..trolley
.t
.try
..trial
zed
double
.dorm
..do
..dormant
..donate
again
.agony
boost
.back
.born

猜懂題目意思真不容易,總之一次最多再縮一格,如果前綴相同的話。

#include <stdio.h>

int main() {
int t;
char s[2][100];
gets(s[0]);
sscanf(s[0], "%d", &t);
gets(s[0]);
while(t--) {
gets(s[0]);
puts(s[0]);
int flag = 1, same = 0, i;
while(gets(s[flag]) && s[flag][0]) {
for(i = 0; s[flag][i] && i <= same; i++) {
if(s[flag][i] != s[1-flag][i])
break;
}
if(i == same+1)
same++;
else
same = i;
for(i = 0; i < same; i++)
putchar(' ');
puts(s[flag]);
flag = 1-flag;
}
if(t)
puts("");
}
return 0;
}

台長: Morris
人氣(1,014) | 回應(1)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][dp] 10201 - Adventures in Moving - Part IV
此分類上一篇:[UVA][NAND] 10144 - Expression

林志
可以加上註解嗎???
2013-06-27 20:45:21
版主回應
需要註解哪裡, 一次最多增一個退格, 檢測一下即可。
2013-06-28 09:50:08
是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文