24h購物| | PChome| 登入
2012-12-31 21:12:37| 人氣2,077| 回應0 | 上一篇 | 下一篇

[UVA][倒水問題][dfs] 10603 - Fill

推薦 0 收藏 0 轉貼0 訂閱站台

 

There are three jugs with a volume of a, b and c liters. (a, b, and c are positive integers not greater than 200). The first and the second jug are initially empty, while the third

is completely filled with water. It is allowed to pour water from one jug into another until either the first one is empty or the second one is full. This operation can be performed zero, one or more times.

 

You are to write a program that computes the least total amount of water that needs to be poured; so that at least one of the jugs contains exactly d liters of water (d is a positive integer not greater than 200). If it is not possible to measure d liters this way your program should find a smaller amount of water d' < d which is closest to d and for which d' liters could be produced. When d' is found, your program should compute the least total amount of poured water needed to produce d' liters in at least one of the jugs.

 

Input

The first line of input contains the number of test cases. In the next T lines, T test cases follow. Each test case is given in one line of input containing four space separated integers - a, b, c and d.

 

Output

The output consists of two integers separated by a single space. The first integer equals the least total amount (the sum of all waters you pour from one jug to another) of poured water. The second integer equals d, if d liters of water could be produced by such transformations, or equals the closest smaller value d' that your program has found.

 

Sample Input

Sample Output

2

2 3 4 2

96 97 199 62

2 2

9859 62

 

Problem source: Bulgarian National Olympiad in Informatics 2003

Problem submitter: Ivaylo Riskov

Problem solution: Ivaylo Riskov, Sadrul Habib Chowdhury


dfs 下去跑。



#include <stdio.h>
#define min(x, y) ((x) < (y) ? (x) : (y))
#define oo 0xfffffff
int A, B, C, D, JUG[3];
int dp[201][201][201], res[201];
void dfs(int a, int b, int c, int tot) {
    if(tot >= res[D])   return;
    if(tot >= dp[a][b][c])  return;
    dp[a][b][c] = tot;
    res[a] = min(res[a], tot);
    res[b] = min(res[b], tot);
    res[c] = min(res[c], tot);
    if(a < B-b) dfs(0, b+a, c, tot+a);
    else        dfs(a-(B-b), B, c, tot+(B-b));
    if(a < C-c) dfs(0, b, c+a, tot+a);
    else        dfs(a-(C-c), b, C, tot+(C-c));
    if(b < A-a) dfs(a+b, 0, c, tot+b);
    else        dfs(A, b-(A-a), c, tot+(A-a));
    if(b < C-c) dfs(a, 0, c+b, tot+b);
    else        dfs(a, b-(C-c), C, tot+(C-c));
    if(c < A-a) dfs(a+c, b, 0, tot+c);
    else        dfs(A, b, c-(A-a), tot+(A-a));
    if(c < B-b) dfs(a, b+c, 0, tot+c);
    else        dfs(a, B, c-(B-b), tot+(B-b));

}
int main() {
    int t;
    scanf("%d", &t);
    while(t--) {
        int i, j, k;
        scanf("%d %d %d %d", &A, &B, &C, &D);
        for(i = 0; i <= A; i++)
            for(j = 0; j <= B; j++)
                for(k = 0; k <= C; k++)
                    dp[i][j][k] = oo;
        JUG[0] = A, JUG[1] = B, JUG[2] = C;
        for(i = 0; i <= D; i++)
            res[i] = oo;
        dfs(0, 0, C, 0);
        while(res[D] == oo) D--;
        printf("%d %d\n", res[D], D);
    }
    return 0;
}

台長: Morris
人氣(2,077) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][bfs] 11049 - Basic wall maze
此分類上一篇:[UVA][KM算法] 10746 - Crime Wave - The Sequel

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文