24h購物| | PChome| 登入
2012-07-13 09:22:59| 人氣1,298| 回應0 | 上一篇 | 下一篇

[UVA][Java] 10007 - Count the Trees

推薦 0 收藏 0 轉貼0 訂閱站台


  Count the Trees 

Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.

Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.


begin{picture}(400,90)(50,0)
put(115,62){A}
put(75,10){B}
put(120,60){vecto...
...}}
put(365,62){B}
put(405,10){A}
put(370,60){vector(1,-1){40}}
end{picture}

If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

Input 

The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 300 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.

Output 

For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.

Sample Input 

1
2
10
25
0

Sample Output 

1
4
60949324800
75414671852339208296275849248768000000


Catalan Numbers * n! 即可

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        BigInteger[] f = new BigInteger[301];
        BigInteger[] g = new BigInteger[301];
        f[1] = BigInteger.valueOf(1);
        g[1] = BigInteger.valueOf(1);
        for(int i = 2; i <= 300; i++) {
            f[i] = f[i-1].multiply(BigInteger.valueOf(4*i-2)).divide(BigInteger.valueOf(i+1));
            g[i] = g[i-1].multiply(BigInteger.valueOf(i));
        }
       
        Scanner cin = new Scanner(System.in);
        while(cin.hasNext()) {
            int n = cin.nextInt();
            if(n == 0)
                break;
            System.out.println(f[n].multiply(g[n]));
        }
    }
}

台長: Morris
人氣(1,298) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA][JAVA] 10464 - Big Big Real Numbers
此分類上一篇:[UVA] 10539 - Almost Prime Numbers

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文