24h購物| | PChome| 登入
2012-04-16 21:24:44| 人氣1,138| 回應0 | 上一篇 | 下一篇

[UVA][Greedy] 11369 - Shopaholic

推薦 0 收藏 0 轉貼0 訂閱站台


  H: Shopaholic 

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet.

epsfbox{p11369.eps}

You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350.

Your job is to find the maximum discount Lindsay can get.

Input 

The first line of input gives the number of test scenarios, 1$ le$t$ le$20 . Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1$ le$n$ le$20000 . The next line gives the prices of these items, 1$ le$pi$ le$20000 .

Output 

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input 

1 
6 
400 100 200 350 300 250

Sample Output 

400

排序後挑 3 的倍數的值
 

#include <stdio.h>

int ReadInt(int *x) {
    static char c, neg;
    while((c = getchar()) < '-')    {if(c == EOF) return EOF;}
    neg = (c == '-') ? -1 : 1;
    *x = (neg == 1) ? c-'0' : 0;
    while((c = getchar()) >= '0')
        *x = (*x << 3) + (*x << 1) + c-'0';
    *x *= neg;
    return 1;
}
int main() {
    int t, n, p;
    scanf("%d", &t);
    while(t--) {
        ReadInt(&n);
        int count[20001] = {}, sum = 0;
        while(n--) {
            ReadInt(&p);
            count[p]++;
        }
        int flag = 0, i, j;
        for(i = 20000; i >= 1; i--) {
            for(j = 0; j < count[i]; j++) {
                flag++;
                if(flag%3 == 0)
                    sum += i;
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}


台長: Morris
人氣(1,138) | 回應(0)| 推薦 (0)| 收藏 (0)| 轉寄
全站分類: 不分類 | 個人分類: UVA |
此分類下一篇:[UVA] 544 - Heavy Cargo
此分類上一篇:[UVA][Negative Weight Cycle] 558 - Wormholes

是 (若未登入"個人新聞台帳號"則看不到回覆唷!)
* 請輸入識別碼:
請輸入圖片中算式的結果(可能為0) 
(有*為必填)
TOP
詳全文